setMetadata("Label", string) ineffective on single images?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

setMetadata("Label", string) ineffective on single images?

Bill Christens-Barry-2
Since updating to ImageJ 1.52c on MacOS 10.11.6 with Java 1.6.0_65 [64-bit], I've noticed that the macro command setMetadata("Label", <string>) is only effective here with stack slices and isn't effective with single images. This behavior may predate this recent update, although the current online documentation indicates that the command should work with single images.

Has this been seen by other users?

Thanks.

Bill Christens-Barry

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: setMetadata("Label", string) ineffective on single images?

Wayne Rasband-2
> On May 22, 2018, at 9:51 PM, Bill Christens-Barry <[hidden email]> wrote:
>
> Since updating to ImageJ 1.52c on MacOS 10.11.6 with Java 1.6.0_65 [64-bit], I've noticed that the macro command setMetadata("Label", <string>) is only effective here with stack slices and isn't effective with single images. This behavior may predate this recent update, although the current online documentation indicates that the command should work with single images.

The latest ImageJ daily build (1.52d3) fixes a 1.52b regression that caused labels set with the setMetadata("Label",label) macro function to not be displayed in the subtitle of single images.

-wayne

> Has this been seen by other users?
>
> Thanks.
>
> Bill Christens-Barry

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html