duplicate classes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

duplicate classes

Kenneth R Sloan-2
I have been sloppy, and have created plugins with duplicate classes.  In the past, this worked just fine (ImageJ seems to have found the FIRST instance installed, and used that one without complaint).

[yes...yes...I'm in the process of cleaning this up]

But now, I find that ImageJ complains "can't find class - and then points out that there are duplicates".  And stops.

While this may be a good incentive for me to clean things up, I'm wondering what changed, and why.

My current "the deadline is in 30 min" workaround is to uninstall all but the currently required plugins.  Almost workable enough for me to NOT clean things up, but not quite.

My original motivation was that I wanted various plugins to be "standalone" and all buildable from one source directory.  That ship has now sailed, and I'm paying the price.  But, again - has something changed recently to trigger this behavior?  Or, should I be looking for some other problem?

Best I can tell is that this all worked 3 months ago, and was broken last night.

--
Kenneth Sloan
[hidden email]
Vision is the art of seeing what is invisible to others.

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html