Label Stacks skipping time steps

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Label Stacks skipping time steps

Rafael Buono
Dear list,

I am trying to label a time course using Label Stacks (Image>Stacks>Label...) and running into the same trouble again and again. It skips every other time point, resulting in having the same time point for two consecutive frames. This makes, for example, a time series of 205min to be labelled as being of 100min.

I see the same behavior with different files and on two independent computers, both running FIJI with imageJ 1.51a and freshly updated.

Am I missing an option while setting things up with Label Stacks or does this sound like a bug?

Cheers,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Krs5
Dear Rafael,

Not sure, I don't seem to see this problem in the sample image Mitosis. If you check the image properties under Image > Properties... are these correct?

Kees


Dr Ir K.R. Straatman
Senior Experimental Officer
Advanced Imaging Facility
Centre for Core Biotechnology Services
University of Leicester
http://www2.le.ac.uk/colleges/medbiopsych/facilities-and-services/cbs/lite/aif

-----Original Message-----
From: ImageJ Interest Group [mailto:[hidden email]] On Behalf Of Rafael Buono
Sent: 25 May 2016 10:06
To: [hidden email]
Subject: Label Stacks skipping time steps

Dear list,

I am trying to label a time course using Label Stacks (Image>Stacks>Label...) and running into the same trouble again and again. It skips every other time point, resulting in having the same time point for two consecutive frames. This makes, for example, a time series of 205min to be labelled as being of 100min.

I see the same behavior with different files and on two independent computers, both running FIJI with imageJ 1.51a and freshly updated.

Am I missing an option while setting things up with Label Stacks or does this sound like a bug?

Cheers,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Rafael Buono
In reply to this post by Rafael Buono
Dear Kees,

I have tried both with and without the frame interval in image properties being correct and got the same result.
The Mitosis sample image works fine in my system.

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Krs5
Dear Rafael,

Any change you can make a small stack available to see what the problem is?

Kees

-----Original Message-----
From: ImageJ Interest Group [mailto:[hidden email]] On Behalf Of Rafael Buono
Sent: 25 May 2016 12:26
To: [hidden email]
Subject: Re: Label Stacks skipping time steps

Dear Kees,

I have tried both with and without the frame interval in image properties being correct and got the same result.
The Mitosis sample image works fine in my system.

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Rafael Buono
In reply to this post by Rafael Buono
Hi Kees,

Yes.
The stacks are large, so I will just do an extreme crop of one of them.
How do I make it available? Through Help>Upload Sample Image?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Krs5
Hi Rafael,

You can also make a substack (Image > Stacks > Tools > Make Substack.. )

Maybe you have access to a server or can post your image on the web and send a link to the mailing list.

Kees

-----Original Message-----
From: ImageJ Interest Group [mailto:[hidden email]] On Behalf Of Rafael Buono
Sent: 28 May 2016 19:37
To: [hidden email]
Subject: Re: Label Stacks skipping time steps

Hi Kees,

Yes.
The stacks are large, so I will just do an extreme crop of one of them.
How do I make it available? Through Help>Upload Sample Image?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Rafael Buono
In reply to this post by Rafael Buono
Hi Kees,

Here is a link to it:
https://floppy.psb.ugent.be/public.php?service=files&t=4e84133149a330218f9148e49d9fd185

On this one the label was getting stuck in time zero throughout the stack.
Any clues as to what could be causing this?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Krs5
Hi Rafael,

I am afraid I cannot reproduce the problem. The image you made available gives me correctly all time points.

Kees

-----Original Message-----
From: ImageJ Interest Group [mailto:[hidden email]] On Behalf Of Rafael Buono
Sent: 06 June 2016 21:23
To: [hidden email]
Subject: Re: Label Stacks skipping time steps

Hi Kees,

Here is a link to it:
https://floppy.psb.ugent.be/public.php?service=files&t=4e84133149a330218f9148e49d9fd185

On this one the label was getting stuck in time zero throughout the stack.
Any clues as to what could be causing this?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Swayne, Theresa C.

Greetings, Rafael & Kees,

In my hands the labels get “stuck” on 00:00:00 if the overlay is used, but they are correct if drawn onto the image.

Below is a macro (save it as an .ijm file) that reproduces the problem on my system, using the file that Rafael provided.

So if others can reproduce this, I think there may be a bug in the Stack Labeler.


————————————————————————

// open the example image "label issue-1.tif" then run the macro

run("Duplicate...", "duplicate");
selectWindow("label issue-1.tif");
run("Label...", "format=00:00:00 starting=0 interval=300 x=5 y=20 font=18 text=[] range=1-5");
rename("no overlay.tif");
selectWindow("label issue-2.tif");
run("Label...", "format=00:00:00 starting=0 interval=300 x=5 y=20 font=18 text=[] range=1-5 use");
rename("overlay.tif”);
—————————————————————————

On Jun 7, 2016, at 3:40 AM, Straatman, Kees (Dr.) <[hidden email]<mailto:[hidden email]>> wrote:

Hi Rafael,

I am afraid I cannot reproduce the problem. The image you made available gives me correctly all time points.

Kees

-----Original Message-----
From: ImageJ Interest Group [mailto:[hidden email]] On Behalf Of Rafael Buono
Sent: 06 June 2016 21:23
To: [hidden email]<mailto:[hidden email]>
Subject: Re: Label Stacks skipping time steps

Hi Kees,

Here is a link to it:
https://floppy.psb.ugent.be/public.php?service=files&t=4e84133149a330218f9148e49d9fd185

On this one the label was getting stuck in time zero throughout the stack.
Any clues as to what could be causing this?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

------------------------------------
Theresa Swayne, Ph.D.
Manager
Confocal and Specialized Microscopy Shared Resource<http://hiccc.columbia.edu/research/sharedresources/confocal>

Herbert Irving Comprehensive Cancer Center
Columbia University Medical Center
1130 St. Nicholas Ave., Room 222A
New York, NY 10032
Phone: 212-851-4613
[hidden email]<mailto:[hidden email]>


--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

Rafael Buono
In reply to this post by Rafael Buono
Dear Kees and Theresa,

Thank you for the replies and the time spent with this.
I was about to post the macro line for what I was doing:

run("Label...", "format=0 starting=0 interval=5 x=5 y=20 font=18 text=min range=1-5 use");

I have been indeed using the overlay option. If I don't use it, the label works fine. This is true for the example stack I sent and for other stacks.
Should I submit a bug report for this? The Bug Submitter is temporarily unavailable. How can I submit a bug report?

Best,

Rafael

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Label Stacks skipping time steps

ctrueden
Hi Rafael,

> The Bug Submitter is temporarily unavailable. How can I submit a bug
report?

Since this is a potential bug in core ImageJ 1.x, this email thread is
probably sufficient.

Or if you want to submit a patch, you could file a PR for Wayne's perusal
at https://github.com/imagej/imagej1/pulls.

See also:
http://imagej.net/Contributing#ImageJ1

Regards,
Curtis

--
Curtis Rueden
LOCI software architect - http://loci.wisc.edu/software
ImageJ2 lead, Fiji maintainer - http://imagej.net/User:Rueden
Did you know ImageJ has a forum? http://forum.imagej.net/


On Tue, Jun 7, 2016 at 11:33 AM, Rafael Buono <[hidden email]> wrote:

> Dear Kees and Theresa,
>
> Thank you for the replies and the time spent with this.
> I was about to post the macro line for what I was doing:
>
> run("Label...", "format=0 starting=0 interval=5 x=5 y=20 font=18 text=min
> range=1-5 use");
>
> I have been indeed using the overlay option. If I don't use it, the label
> works fine. This is true for the example stack I sent and for other stacks.
> Should I submit a bug report for this? The Bug Submitter is temporarily
> unavailable. How can I submit a bug report?
>
> Best,
>
> Rafael
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html