Inverse Rodbard Initial Guesses

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Inverse Rodbard Initial Guesses

ullala578
Hello,
I am trying to fit in a Macro with Fit.doFit an array with the Inverse Rodbard function. To do this I need to set the Initial Guesses
initialGuesses = newArray(0, 10, 4000, 20);
Fit.doFit(InverseRodbard,x, y,initialGuesses);
It seems that it doesn't work and the result is the same if I don't set the initialGuesses or I change the value. Is there something wrong in the curve fitting macro?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Inverse Rodbard Initial Guesses

Michael Schmid-3
Hi Carla,

do you have a data set to reproduce the problem?
Ideally, a macro with a Minimal, Complete, Verifiable Example (MCVE;
https://stackoverflow.com/help/mcve), or a list of x/y values that one
could paste into the Curve Fitter Window.

E.g. something like the following:

x = newArray(0.1, 1, 3, 4, 7);
y = newArray(80, 110, 120, 122, 129);
Fit.doFit("Inverse Rodbard",x, y);
Fit.plot();
rename("fit without initial guesses");
initialGuesses = newArray(0, 10, 4000, 20);
Fit.doFit("Inverse Rodbard",x, y,initialGuesses);
Fit.plot();

For this test case (and several others that I tried), the result is the
same with and without the initial guess parameters: In both cases, the
fit finds the correct solution.

I am using Imagej 1.51p, but there have not been any relevant changes to
the CurveFitter and Minimizer since at least 1.50a

Michael
________________________________________________________________
On 06/07/2017 17:27, ullala578 wrote:

> Hello,
> I am trying to fit in a Macro with Fit.doFit an array with the Inverse
> Rodbard function. To do this I need to set the Initial Guesses
> initialGuesses = newArray(0, 10, 4000, 20);
> Fit.doFit(InverseRodbard,x, y,initialGuesses);
> It seems that it doesn't work and the result is the same if I don't set the
> initialGuesses or I change the value. Is there something wrong in the curve
> fitting macro?
>
>
>
>
> --
> View this message in context: http://imagej.1557.x6.nabble.com/Inverse-Rodbard-Initial-Guesses-tp5019034.html
> Sent from the ImageJ mailing list archive at Nabble.com.
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Loading...