Duplicate shows no progress bar

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Duplicate shows no progress bar

Stein Rørvik
I usually work with fairly large µCT datasets, stacks of minimum 2000x2000x2000 pixels.
The Duplicate... command works as it should on these, both with normal and virtual stacks.
When opened as virtual stacks, Duplicate shows a progress bar.
But there is no progress bar shown if the stack was loaded in memory, neither when called via the GUI nor a macro.
Even with a fast computer, stacks with 2000^3 pixels might take some time to duplicate so it would be useful to see the progress.

Stein

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate shows no progress bar

Wayne Rasband-2
> On Jan 21, 2019, at 9:21 AM, Stein Rørvik <[hidden email]> wrote:
>
> I usually work with fairly large µCT datasets, stacks of minimum 2000x2000x2000 pixels.
> The Duplicate... command works as it should on these, both with normal and virtual stacks.
> When opened as virtual stacks, Duplicate shows a progress bar.
> But there is no progress bar shown if the stack was loaded in memory, neither when called via the GUI nor a macro.
> Even with a fast computer, stacks with 2000^3 pixels might take some time to duplicate so it would be useful to see the progress.

The ImageJ 1.52k66 daily build displays a progress bar when duplicating large (>200 megapixel) stacks.

-wayne

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate shows no progress bar

Stein Rørvik
Thanks,

it works as advertised but only up until a certain stack size.

See this demo macro:

factor = 7;
run("Close All");
run("T1 Head (2.4M, 16-bits)");
run("Scale...", "x=&factor y=&factor z=&factor interpolation=Bilinear average process create");
run("Duplicate...", "duplicate");

It does show a progress bar at factor 6 (3.4 GB stack size) but shows no progress bar at factor 7 (5.4 GB size). Perhaps there is an overflow:

It runs ok at factor 6.3: 1612*1612*812*2 = 4220035456
It fails at factor 6.4: 1638*1638*825*2 = 4427022600
Max 32-bit integer = 4294967296

Stein

-----Original Message-----
From: ImageJ Interest Group <[hidden email]> On Behalf Of Wayne Rasband
Sent: 23. januar 2019 20:55
To: [hidden email]
Subject: Re: Duplicate shows no progress bar

> On Jan 21, 2019, at 9:21 AM, Stein Rørvik <[hidden email]> wrote:
>
> I usually work with fairly large µCT datasets, stacks of minimum 2000x2000x2000 pixels.
> The Duplicate... command works as it should on these, both with normal and virtual stacks.
> When opened as virtual stacks, Duplicate shows a progress bar.
> But there is no progress bar shown if the stack was loaded in memory, neither when called via the GUI nor a macro.
> Even with a fast computer, stacks with 2000^3 pixels might take some time to duplicate so it would be useful to see the progress.

The ImageJ 1.52k66 daily build displays a progress bar when duplicating large (>200 megapixel) stacks.

-wayne

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html