BioVoxxel odd behavior

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

BioVoxxel odd behavior

Christine Labno-2
Hi All,

I'm seeing some odd behavior from the BioVoxxel Toolbox's Watershed irregular features command (and possibly other components, but didn't test all).

When I use this feature through Fiji (IJ version 1.50b, Windows XP) it works as expected, but when I try to use it though ImageJ (version 1.48, 1.49 or 1.50c Windows XP or Windows 7) I get the error message "Unrecognized command: 'Watershed Irregular Features'".  Both versions of BioVoxxel are fresh downloads, one though the Fiji update site and one downloaded from http://www.biovoxxel.de/development/.  I even tried copying the Fiji version of the BioVoxxel .jars into ImageJ, but this didn't help.  Using exactly the same image each time.

What am I doing wrong?

Thanks!
Christine

--------------------------------------------
Christine Labno, Ph.D.
Asst. Technical Director
Light Microscopy Core
University of Chicago
Office of Shared Research Facilities
KCBD 1250 900 E. 57th St.
(773) 834-9040 (phone)

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: BioVoxxel odd behavior

gankaku
Hi Christine,

thanks for writing.
I am also running Win7 and tried what you mentioned in IJ 1.50c. I could
not confirm any problems.
Please make sure, that you copied the files into the correct folders (see
http://www.biovoxxel.de/development/) the toolset needs to be unpacked into
the >macros>toolsets folder   while the plugins need to be unpacked in the
plugins folder. Important is that the "ij_blob-1.4.0.jar" file is also in
the plugins folder. This is only necessary for the Watershed Irregular
Features command.

If you did all those steps correct, could you try to go to >Plugins
>BioVoxxel >Watershed Irregular Features and start it from there instead
from the "green cube" icon menu.

If the problem still persists I am a little clueless where it comes from.

Is only this one function a problem and do all the others run fine?

Please keep me on the loop, if the problem persists and I will try to
figure out what might be the problem. In that case you might as well post
the problem on forum.imagej.net
So we will potentially see if others also have had the same problem.

Kind regards,
Jan



2015-10-07 18:15 GMT+02:00 Christine Labno <[hidden email]>:

> Hi All,
>
> I'm seeing some odd behavior from the BioVoxxel Toolbox's Watershed
> irregular features command (and possibly other components, but didn't test
> all).
>
> When I use this feature through Fiji (IJ version 1.50b, Windows XP) it
> works as expected, but when I try to use it though ImageJ (version 1.48,
> 1.49 or 1.50c Windows XP or Windows 7) I get the error message
> "Unrecognized command: 'Watershed Irregular Features'".  Both versions of
> BioVoxxel are fresh downloads, one though the Fiji update site and one
> downloaded from http://www.biovoxxel.de/development/.  I even tried
> copying the Fiji version of the BioVoxxel .jars into ImageJ, but this
> didn't help.  Using exactly the same image each time.
>
> What am I doing wrong?
>
> Thanks!
> Christine
>
> --------------------------------------------
> Christine Labno, Ph.D.
> Asst. Technical Director
> Light Microscopy Core
> University of Chicago
> Office of Shared Research Facilities
> KCBD 1250 900 E. 57th St.
> (773) 834-9040 (phone)
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>



--

CEO: Dr. rer. nat. Jan Brocher
phone:  +49 (0)6234 917 03 39
mobile: +49 (0)176 705 746 81
e-mail: [hidden email]
info: [hidden email]
inquiries: [hidden email]
web: www.biovoxxel.de

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: BioVoxxel odd behavior

Christine Labno-2
Hi Jan,

Thanks for replying.  

You are correct, I missed the second step of downloading and unpacking the "plugins" section of BioVoxxel into my ImageJ Plugins folder.  Once I did that Watershed Irregular Features worked from both the green cube menu in the toolsets and the Plugins menu.  

Still waiting to get feedback from the colleague I'm working with who was having the same problem, but I think this fix should work for him too.

Thanks for the help and the great toolset!
Christine
--------------------------------------------
Christine Labno, Ph.D.
Asst. Technical Director
Light Microscopy Core
University of Chicago
Office of Shared Research Facilities
KCBD 1250 900 E. 57th St.
(773) 834-9040 (phone)

________________________________________
From: ImageJ Interest Group [[hidden email]] on behalf of BioVoxxel [[hidden email]]
Sent: Wednesday, October 07, 2015 1:05 PM
To: [hidden email]
Subject: Re: BioVoxxel odd behavior

Hi Christine,

thanks for writing.
I am also running Win7 and tried what you mentioned in IJ 1.50c. I could
not confirm any problems.
Please make sure, that you copied the files into the correct folders (see
http://www.biovoxxel.de/development/) the toolset needs to be unpacked into
the >macros>toolsets folder   while the plugins need to be unpacked in the
plugins folder. Important is that the "ij_blob-1.4.0.jar" file is also in
the plugins folder. This is only necessary for the Watershed Irregular
Features command.

If you did all those steps correct, could you try to go to >Plugins
>BioVoxxel >Watershed Irregular Features and start it from there instead
from the "green cube" icon menu.

If the problem still persists I am a little clueless where it comes from.

Is only this one function a problem and do all the others run fine?

Please keep me on the loop, if the problem persists and I will try to
figure out what might be the problem. In that case you might as well post
the problem on forum.imagej.net
So we will potentially see if others also have had the same problem.

Kind regards,
Jan



2015-10-07 18:15 GMT+02:00 Christine Labno <[hidden email]>:

> Hi All,
>
> I'm seeing some odd behavior from the BioVoxxel Toolbox's Watershed
> irregular features command (and possibly other components, but didn't test
> all).
>
> When I use this feature through Fiji (IJ version 1.50b, Windows XP) it
> works as expected, but when I try to use it though ImageJ (version 1.48,
> 1.49 or 1.50c Windows XP or Windows 7) I get the error message
> "Unrecognized command: 'Watershed Irregular Features'".  Both versions of
> BioVoxxel are fresh downloads, one though the Fiji update site and one
> downloaded from http://www.biovoxxel.de/development/.  I even tried
> copying the Fiji version of the BioVoxxel .jars into ImageJ, but this
> didn't help.  Using exactly the same image each time.
>
> What am I doing wrong?
>
> Thanks!
> Christine
>
> --------------------------------------------
> Christine Labno, Ph.D.
> Asst. Technical Director
> Light Microscopy Core
> University of Chicago
> Office of Shared Research Facilities
> KCBD 1250 900 E. 57th St.
> (773) 834-9040 (phone)
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>



--

CEO: Dr. rer. nat. Jan Brocher
phone:  +49 (0)6234 917 03 39
mobile: +49 (0)176 705 746 81
e-mail: [hidden email]
info: [hidden email]
inquiries: [hidden email]
web: www.biovoxxel.de

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: BioVoxxel odd behavior

Kala Nair
Hi

I am using image j for the first time. i wanted to do densitimetry for dab
stained sections individual neurons. it would be great if someone help me
how to g about it. which magnification i have to take images and what are
the steps to do.

Ms. Kala P. Nair
Junior Research Intern
C/O Dr. Vijayalakshmi Ravindranath
Center for Neuroscience
Indian Institute of Science
Bengaluru - 560012
E-Mail : [hidden email]
Ph No: +91- 7406649641

On Tue, Oct 13, 2015 at 9:54 PM, Christine Labno <[hidden email]> wrote:

> Hi Jan,
>
> Thanks for replying.
>
> You are correct, I missed the second step of downloading and unpacking the
> "plugins" section of BioVoxxel into my ImageJ Plugins folder.  Once I did
> that Watershed Irregular Features worked from both the green cube menu in
> the toolsets and the Plugins menu.
>
> Still waiting to get feedback from the colleague I'm working with who was
> having the same problem, but I think this fix should work for him too.
>
> Thanks for the help and the great toolset!
> Christine
> --------------------------------------------
> Christine Labno, Ph.D.
> Asst. Technical Director
> Light Microscopy Core
> University of Chicago
> Office of Shared Research Facilities
> KCBD 1250 900 E. 57th St.
> (773) 834-9040 (phone)
>
> ________________________________________
> From: ImageJ Interest Group [[hidden email]] on behalf of BioVoxxel [
> [hidden email]]
> Sent: Wednesday, October 07, 2015 1:05 PM
> To: [hidden email]
> Subject: Re: BioVoxxel odd behavior
>
> Hi Christine,
>
> thanks for writing.
> I am also running Win7 and tried what you mentioned in IJ 1.50c. I could
> not confirm any problems.
> Please make sure, that you copied the files into the correct folders (see
> http://www.biovoxxel.de/development/) the toolset needs to be unpacked
> into
> the >macros>toolsets folder   while the plugins need to be unpacked in the
> plugins folder. Important is that the "ij_blob-1.4.0.jar" file is also in
> the plugins folder. This is only necessary for the Watershed Irregular
> Features command.
>
> If you did all those steps correct, could you try to go to >Plugins
> >BioVoxxel >Watershed Irregular Features and start it from there instead
> from the "green cube" icon menu.
>
> If the problem still persists I am a little clueless where it comes from.
>
> Is only this one function a problem and do all the others run fine?
>
> Please keep me on the loop, if the problem persists and I will try to
> figure out what might be the problem. In that case you might as well post
> the problem on forum.imagej.net
> So we will potentially see if others also have had the same problem.
>
> Kind regards,
> Jan
>
>
>
> 2015-10-07 18:15 GMT+02:00 Christine Labno <[hidden email]>:
>
> > Hi All,
> >
> > I'm seeing some odd behavior from the BioVoxxel Toolbox's Watershed
> > irregular features command (and possibly other components, but didn't
> test
> > all).
> >
> > When I use this feature through Fiji (IJ version 1.50b, Windows XP) it
> > works as expected, but when I try to use it though ImageJ (version 1.48,
> > 1.49 or 1.50c Windows XP or Windows 7) I get the error message
> > "Unrecognized command: 'Watershed Irregular Features'".  Both versions of
> > BioVoxxel are fresh downloads, one though the Fiji update site and one
> > downloaded from http://www.biovoxxel.de/development/.  I even tried
> > copying the Fiji version of the BioVoxxel .jars into ImageJ, but this
> > didn't help.  Using exactly the same image each time.
> >
> > What am I doing wrong?
> >
> > Thanks!
> > Christine
> >
> > --------------------------------------------
> > Christine Labno, Ph.D.
> > Asst. Technical Director
> > Light Microscopy Core
> > University of Chicago
> > Office of Shared Research Facilities
> > KCBD 1250 900 E. 57th St.
> > (773) 834-9040 (phone)
> >
> > --
> > ImageJ mailing list: http://imagej.nih.gov/ij/list.html
> >
>
>
>
> --
>
> CEO: Dr. rer. nat. Jan Brocher
> phone:  +49 (0)6234 917 03 39
> mobile: +49 (0)176 705 746 81
> e-mail: [hidden email]
> info: [hidden email]
> inquiries: [hidden email]
> web: www.biovoxxel.de
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|

Re: BioVoxxel odd behavior

gankaku
Hi Kala,

Sad but true... you can't really quantify DAB staining by densiometry.
This discussion was up here already several times and Gabriel Landini
answered it e.g. in this post (
https://list.nih.gov/cgi-bin/wa.exe?A2=IMAGEJ;ec89a423.1401) and that one (
https://list.nih.gov/cgi-bin/wa.exe?A2=IMAGEJ;aa393957.1401).

Addtionally, you might want to have a look at this one:
https://list.nih.gov/cgi-bin/wa.exe?A2=ind0902&L=IMAGEJ&P=R18412

Or on G. Landinis' Homepage:
http://www.mecourse.com/landinig/software/cdeconv/cdeconv.html

Hope it gives you some info.
regards,
Jan




2015-10-14 7:38 GMT+02:00 Kala Nair <[hidden email]>:

> Hi
>
> I am using image j for the first time. i wanted to do densitimetry for dab
> stained sections individual neurons. it would be great if someone help me
> how to g about it. which magnification i have to take images and what are
> the steps to do.
>
> Ms. Kala P. Nair
> Junior Research Intern
> C/O Dr. Vijayalakshmi Ravindranath
> Center for Neuroscience
> Indian Institute of Science
> Bengaluru - 560012
> E-Mail : [hidden email]
> Ph No: +91- 7406649641
>
> On Tue, Oct 13, 2015 at 9:54 PM, Christine Labno <[hidden email]>
> wrote:
>
> > Hi Jan,
> >
> > Thanks for replying.
> >
> > You are correct, I missed the second step of downloading and unpacking
> the
> > "plugins" section of BioVoxxel into my ImageJ Plugins folder.  Once I did
> > that Watershed Irregular Features worked from both the green cube menu in
> > the toolsets and the Plugins menu.
> >
> > Still waiting to get feedback from the colleague I'm working with who was
> > having the same problem, but I think this fix should work for him too.
> >
> > Thanks for the help and the great toolset!
> > Christine
> > --------------------------------------------
> > Christine Labno, Ph.D.
> > Asst. Technical Director
> > Light Microscopy Core
> > University of Chicago
> > Office of Shared Research Facilities
> > KCBD 1250 900 E. 57th St.
> > (773) 834-9040 (phone)
> >
> > ________________________________________
> > From: ImageJ Interest Group [[hidden email]] on behalf of
> BioVoxxel [
> > [hidden email]]
> > Sent: Wednesday, October 07, 2015 1:05 PM
> > To: [hidden email]
> > Subject: Re: BioVoxxel odd behavior
> >
> > Hi Christine,
> >
> > thanks for writing.
> > I am also running Win7 and tried what you mentioned in IJ 1.50c. I could
> > not confirm any problems.
> > Please make sure, that you copied the files into the correct folders (see
> > http://www.biovoxxel.de/development/) the toolset needs to be unpacked
> > into
> > the >macros>toolsets folder   while the plugins need to be unpacked in
> the
> > plugins folder. Important is that the "ij_blob-1.4.0.jar" file is also in
> > the plugins folder. This is only necessary for the Watershed Irregular
> > Features command.
> >
> > If you did all those steps correct, could you try to go to >Plugins
> > >BioVoxxel >Watershed Irregular Features and start it from there instead
> > from the "green cube" icon menu.
> >
> > If the problem still persists I am a little clueless where it comes from.
> >
> > Is only this one function a problem and do all the others run fine?
> >
> > Please keep me on the loop, if the problem persists and I will try to
> > figure out what might be the problem. In that case you might as well post
> > the problem on forum.imagej.net
> > So we will potentially see if others also have had the same problem.
> >
> > Kind regards,
> > Jan
> >
> >
> >
> > 2015-10-07 18:15 GMT+02:00 Christine Labno <[hidden email]>:
> >
> > > Hi All,
> > >
> > > I'm seeing some odd behavior from the BioVoxxel Toolbox's Watershed
> > > irregular features command (and possibly other components, but didn't
> > test
> > > all).
> > >
> > > When I use this feature through Fiji (IJ version 1.50b, Windows XP) it
> > > works as expected, but when I try to use it though ImageJ (version
> 1.48,
> > > 1.49 or 1.50c Windows XP or Windows 7) I get the error message
> > > "Unrecognized command: 'Watershed Irregular Features'".  Both versions
> of
> > > BioVoxxel are fresh downloads, one though the Fiji update site and one
> > > downloaded from http://www.biovoxxel.de/development/.  I even tried
> > > copying the Fiji version of the BioVoxxel .jars into ImageJ, but this
> > > didn't help.  Using exactly the same image each time.
> > >
> > > What am I doing wrong?
> > >
> > > Thanks!
> > > Christine
> > >
> > > --------------------------------------------
> > > Christine Labno, Ph.D.
> > > Asst. Technical Director
> > > Light Microscopy Core
> > > University of Chicago
> > > Office of Shared Research Facilities
> > > KCBD 1250 900 E. 57th St.
> > > (773) 834-9040 (phone)
> > >
> > > --
> > > ImageJ mailing list: http://imagej.nih.gov/ij/list.html
> > >
> >
> >
> >
> > --
> >
> > CEO: Dr. rer. nat. Jan Brocher
> > phone:  +49 (0)6234 917 03 39
> > mobile: +49 (0)176 705 746 81
> > e-mail: [hidden email]
> > info: [hidden email]
> > inquiries: [hidden email]
> > web: www.biovoxxel.de
> >
> > --
> > ImageJ mailing list: http://imagej.nih.gov/ij/list.html
> >
> > --
> > ImageJ mailing list: http://imagej.nih.gov/ij/list.html
> >
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>



--

CEO: Dr. rer. nat. Jan Brocher
phone:  +49 (0)6234 917 03 39
mobile: +49 (0)176 705 746 81
e-mail: [hidden email]
info: [hidden email]
inquiries: [hidden email]
web: www.biovoxxel.de

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html