Quantcast

3D Viewer dependencies on OS X

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

3D Viewer dependencies on OS X

John Hayes
Hi all,

I was wondering if someone knows the Java3D-related dependencies on OS X El Capitan for the 3D Viewer (http://3dviewer.neurofly.de/). I’m a bit confused which .jars are required and what version of Jogl it needs because I believe the newest Jogl made some API changes that are incompatible with the 3D Viewer code I saw.

My version of java is 1.8.0_92.

Thanks,
John
--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3D Viewer dependencies on OS X

ctrueden
Hi John,

> I was wondering if someone knows the Java3D-related dependencies on OS
> X El Capitan for the 3D Viewer

In general, the 3D Viewer dependencies are outlined in its POM:
    https://github.com/fiji/3D_Viewer/blob/3D_Viewer-4.0.1/pom.xml#L127-L159

I assume you are trying to use the new SciJava fork of Java 3D 1.6.0, which
ships on the Java-8 update site? If so, the artifacts are:

org.scijava:j3dcore:1.6.0-scijava-2
http://maven.imagej.net/#nexus-search;gav~org.scijava~j3dcore~1.6.0-scijava-2~~
https://github.com/scijava/java3d-core

org.scijava:j3dutils:1.6.0-scijava-2
http://maven.imagej.net/#nexus-search;gav~org.scijava~j3dutils~1.6.0-scijava-2~~
https://github.com/scijava/java3d-utils

org.scijava:vecmath:1.6.0-scijava-2
http://maven.imagej.net/#nexus-search;gav~org.scijava~vecmath~1.6.0-scijava-2~~
https://github.com/scijava/vecmath

Check the POMs for the dependencies.

> I’m a bit confused which .jars are required and what version of Jogl
> it needs because I believe the newest Jogl made some API changes that
> are incompatible with the 3D Viewer code I saw.

The code in the linked GitHub repository above depends on JOGL 2.3.2, which
AFAIK is still the newest release.

Regards,
Curtis

--
Curtis Rueden
LOCI software architect - http://loci.wisc.edu/software
ImageJ2 lead, Fiji maintainer - http://imagej.net/User:Rueden
Did you know ImageJ has a forum? http://forum.imagej.net/


On Mon, Oct 31, 2016 at 4:14 PM, John Hayes <[hidden email]> wrote:

> Hi all,
>
> I was wondering if someone knows the Java3D-related dependencies on OS X
> El Capitan for the 3D Viewer (http://3dviewer.neurofly.de/). I’m a bit
> confused which .jars are required and what version of Jogl it needs because
> I believe the newest Jogl made some API changes that are incompatible with
> the 3D Viewer code I saw.
>
> My version of java is 1.8.0_92.
>
> Thanks,
> John
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3D Viewer dependencies on OS X

John Hayes
Hi Curtis,

Thanks for the response! One key point of confusion for me might be, is this the same (or perhaps newest) version of the 3D Viewer on the neurofly website I linked to? This is certainly the Fiji one it seems (which is the one I wanted), so maybe I’m using the wrong 3D Viewer jar.

Thanks again,
John

> On Nov 1, 2016, at 9:24 PM, Curtis Rueden <[hidden email]> wrote:
>
> Hi John,
>
>> I was wondering if someone knows the Java3D-related dependencies on OS
>> X El Capitan for the 3D Viewer
>
> In general, the 3D Viewer dependencies are outlined in its POM:
>    https://github.com/fiji/3D_Viewer/blob/3D_Viewer-4.0.1/pom.xml#L127-L159
>
> I assume you are trying to use the new SciJava fork of Java 3D 1.6.0, which
> ships on the Java-8 update site? If so, the artifacts are:
>
> org.scijava:j3dcore:1.6.0-scijava-2
> http://maven.imagej.net/#nexus-search;gav~org.scijava~j3dcore~1.6.0-scijava-2~~
> https://github.com/scijava/java3d-core
>
> org.scijava:j3dutils:1.6.0-scijava-2
> http://maven.imagej.net/#nexus-search;gav~org.scijava~j3dutils~1.6.0-scijava-2~~
> https://github.com/scijava/java3d-utils
>
> org.scijava:vecmath:1.6.0-scijava-2
> http://maven.imagej.net/#nexus-search;gav~org.scijava~vecmath~1.6.0-scijava-2~~
> https://github.com/scijava/vecmath
>
> Check the POMs for the dependencies.
>
>> I’m a bit confused which .jars are required and what version of Jogl
>> it needs because I believe the newest Jogl made some API changes that
>> are incompatible with the 3D Viewer code I saw.
>
> The code in the linked GitHub repository above depends on JOGL 2.3.2, which
> AFAIK is still the newest release.
>
> Regards,
> Curtis
>
> --
> Curtis Rueden
> LOCI software architect - http://loci.wisc.edu/software
> ImageJ2 lead, Fiji maintainer - http://imagej.net/User:Rueden
> Did you know ImageJ has a forum? http://forum.imagej.net/
>
>
> On Mon, Oct 31, 2016 at 4:14 PM, John Hayes <[hidden email]> wrote:
>
>> Hi all,
>>
>> I was wondering if someone knows the Java3D-related dependencies on OS X
>> El Capitan for the 3D Viewer (http://3dviewer.neurofly.de/). I’m a bit
>> confused which .jars are required and what version of Jogl it needs because
>> I believe the newest Jogl made some API changes that are incompatible with
>> the 3D Viewer code I saw.
>>
>> My version of java is 1.8.0_92.
>>
>> Thanks,
>> John
>> --
>> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>>
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3D Viewer dependencies on OS X

ctrueden
Hi John,

Sorry for dropping the ball on this thread till now.

> One key point of confusion for me might be, is this the same (or
> perhaps newest) version of the 3D Viewer on the neurofly website I
> linked to?

The neurofly website is the site of the original 3D Viewer author Bene
Schmid, who no longer maintains or supports it.

I have been wanting to migrate the content from there to the ImageJ wiki
page https://imagej.net/3D_Viewer, but have not had the time.

The latest version of the 3D Viewer source which ships with Fiji is
https://github.com/fiji/3D_Viewer.

I do not know which version of 3D Viewer ships with plain ImageJ 1.x, but I
presume an older one.

Regards,
Curtis

--
Curtis Rueden
LOCI software architect - https://loci.wisc.edu/software
ImageJ2 lead, Fiji maintainer - https://imagej.net/User:Rueden
Did you know ImageJ has a forum? http://forum.imagej.net/


On Wed, Nov 2, 2016 at 3:44 PM, John Hayes <[hidden email]> wrote:

> Hi Curtis,
>
> Thanks for the response! One key point of confusion for me might be, is
> this the same (or perhaps newest) version of the 3D Viewer on the neurofly
> website I linked to? This is certainly the Fiji one it seems (which is the
> one I wanted), so maybe I’m using the wrong 3D Viewer jar.
>
> Thanks again,
> John
>
> > On Nov 1, 2016, at 9:24 PM, Curtis Rueden <[hidden email]> wrote:
> >
> > Hi John,
> >
> >> I was wondering if someone knows the Java3D-related dependencies on OS
> >> X El Capitan for the 3D Viewer
> >
> > In general, the 3D Viewer dependencies are outlined in its POM:
> >    https://github.com/fiji/3D_Viewer/blob/3D_Viewer-4.0.1/
> pom.xml#L127-L159
> >
> > I assume you are trying to use the new SciJava fork of Java 3D 1.6.0,
> which
> > ships on the Java-8 update site? If so, the artifacts are:
> >
> > org.scijava:j3dcore:1.6.0-scijava-2
> > http://maven.imagej.net/#nexus-search;gav~org.scijava~
> j3dcore~1.6.0-scijava-2~~
> > https://github.com/scijava/java3d-core
> >
> > org.scijava:j3dutils:1.6.0-scijava-2
> > http://maven.imagej.net/#nexus-search;gav~org.scijava~
> j3dutils~1.6.0-scijava-2~~
> > https://github.com/scijava/java3d-utils
> >
> > org.scijava:vecmath:1.6.0-scijava-2
> > http://maven.imagej.net/#nexus-search;gav~org.scijava~
> vecmath~1.6.0-scijava-2~~
> > https://github.com/scijava/vecmath
> >
> > Check the POMs for the dependencies.
> >
> >> I’m a bit confused which .jars are required and what version of Jogl
> >> it needs because I believe the newest Jogl made some API changes that
> >> are incompatible with the 3D Viewer code I saw.
> >
> > The code in the linked GitHub repository above depends on JOGL 2.3.2,
> which
> > AFAIK is still the newest release.
> >
> > Regards,
> > Curtis
> >
> > --
> > Curtis Rueden
> > LOCI software architect - http://loci.wisc.edu/software
> > ImageJ2 lead, Fiji maintainer - http://imagej.net/User:Rueden
> > Did you know ImageJ has a forum? http://forum.imagej.net/
> >
> >
> > On Mon, Oct 31, 2016 at 4:14 PM, John Hayes <[hidden email]> wrote:
> >
> >> Hi all,
> >>
> >> I was wondering if someone knows the Java3D-related dependencies on OS X
> >> El Capitan for the 3D Viewer (http://3dviewer.neurofly.de/). I’m a bit
> >> confused which .jars are required and what version of Jogl it needs
> because
> >> I believe the newest Jogl made some API changes that are incompatible
> with
> >> the 3D Viewer code I saw.
> >>
> >> My version of java is 1.8.0_92.
> >>
> >> Thanks,
> >> John
> >> --
> >> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
> >>
> >
> > --
> > ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>
> --
> ImageJ mailing list: http://imagej.nih.gov/ij/list.html
>

--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html
Loading...