3D Suite - 3D Distance map, file input bug?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

3D Suite - 3D Distance map, file input bug?

Matthew Jones
Hi,

I may have found a small bug which affects the distance map output of the 3D Suite’s distance map plugin though I believe it may result from a file format discrepancy. I am quantifying the position of an object within a 3D space based on a a binary image derived from a confocal stack which I convert to a distance map using the distance map plugin (specifically the EVF option, but EDT has the same output quirk). Typical output when all is working looks like the attached file (goodEVF-screenshot). However, some of my images are converted to a lower resolution ’stepped’ map which seems to collapse a lot of the spatial gradient into just a couple of bins (e.g. badEVF-screenshot - also attached).

I tried converting the input files from 8-bit to 32-bit and removing the scale on the image but neither solved the problem.

Now I have inspected the "Info for…” window the metadata suggests that the correct input has additional information that is missing in the files that are not working. It seems the two images are in some way differently formatted, however, I would be very grateful if someone might be able to take a look at this metadata and explain to me what is different about the two files and how one might convert from one to the other as they are both 8-bit binary images saved as Tiff to the best of my knowledge and so only the metadata is different as far as I can tell. Both metadata files are attached. I’ve copied the metadata, original files and output to a folder at the following google drive link  https://drive.google.com/drive/folders/0B_9C1WFBZYoUbzRBVE5nUXJrWDg?usp=sharing <https://drive.google.com/drive/folders/0B_9C1WFBZYoUbzRBVE5nUXJrWDg?usp=sharing>

Hopefully the filenames names are self-explanatory and the input files will reproduce the problem if run through the distance map plugin.

Please let me know if you can’t access, and how best to send the images.

A side note, but potentially related bug, in some instances, opening the distance maps produces a plain grey confocal stack, including when reopening the saved tif ‘goodEVF.tif’ in the attached zip file. In other words, I am unable to save the distance maps and reopen them as grayscale tifs without losing the information.

I would be grateful for any thoughts or background on the different file formats that might be causing these bugs, I’m aware there are many different types of Tiff, but I don’t know much more than that,

Also, a big thank you to Thomas Boudier for 3D Suite and related plugins as they have been invaluable in my research and generally work excellently!

Kind regards,

Matt

p.s. my system is  Macbook Pro OS X Yosemite 10.10.3 and FIJI (though some of the images may have been processed in an older version of ImageJ at an earlier stage).
--
ImageJ mailing list: http://imagej.nih.gov/ij/list.html

badEVF-screenshot.jpeg (54K) Download Attachment
goodEVF-screenshot.jpeg (37K) Download Attachment
badinput-info.txt (2K) Download Attachment
goodinput-info.txt (2K) Download Attachment
Loading...